求相对强度指标股票程序

求相对强度指标股票程序
09-03-03  鱼鱼有梦 发布
3个回答
时间
投票
  • 0

    huihuishiwo

    DRAWGBK(DATE>900101,COLORRGB(0,15,13),COLORRGB(0,0,0),1);
    RSV:=(C-LLV(L,49))/(HHV(H,49)-LLV(L,49))*100;{kdj变型的摆动线}
    变型:=SMA(RSV,100,99);{kdj变型的K线}
    短1:=SMA(变型,3,2);{移动平均线}
    中1:=SMA(短1,8,1);{移动平均线}
    fillrgn(短1<中1,短1,中1),Color6EBB6E;
    fillrgn(短1>中1,短1,中1),ColorD6A6FF;
    短:短1,PRECISION2,ColorFF00FF;
    中:中1,PRECISION2,Color00FFFF;
    强弱界:SMA(短1,120,1),PRECISION2,LINETHICK2,Color009C00;{移动平均线}
    LC := REF(C,1);
    LCDP:= REF(INDEXC,1);
    个股:SMA(MAX(C-LC,0),14,1)/SMA(ABS(C-LC),14,1)*100,PRECISION2,LINETHICK2,Color0000FF;
    大盘:SMA(MAX(INDEXC-LCDP,0),14,1)/SMA(ABS(INDEXC-LCDP),14,1)*100,PRECISION2,LINETHICK2,ColorFF0000;
    aa:个股/大盘;
    FILLRGN(个股>大盘, 个股,大盘),colorred;
    FILLRGN(个股<大盘, 个股,大盘),colorblue;
    20 linethick2 colorgray;
    50 linethick2 coloryellow;
    80 linethick2 colorgreen;

    看大盘炒个股

    09-03-03 | 添加评论 | 打赏

    评论读取中....

  • 0

    ri429ee68

    这个可以按照自己的习惯定义,比如你可以画几条线(1)大盘涨跌幅度的数值连线(比如3%你就可以定为3)(2)(1)个股的涨跌幅度数值连线,通过两条线你能很直观的看出它近期强于大盘还是弱于大盘,(3)然后你也可以再定义一个强度值=个股的涨跌百分比-大盘涨跌百分比,然后做一个每天的连线。



    注:这些自定义的东西,每个人习惯不同,呵呵,你将来也可以根据个人需要再不断的完善改进

    09-10-24 | 添加评论 | 打赏

    评论读取中....

精华知识
更多  
意见反馈 帮助